Retour à l'aperçu
Résolu

Zelden Offline

Oct 9, 2024 at 6:39pm UTC
Services affectés
Zelden

Résolu
Oct 9, 2024 at 7:24pm UTC

Zelden è tornato online.

Créé
Oct 9, 2024 at 6:39pm UTC

Zelden è offline per problemi interni, tornerà online il più presto possibile.
Ci scusiamo per il disagio.
- Goldy ~ Staff Team